Support Forum

Home Forums OceanPlaza WP Images didnt set up correctly on mobile version (not responsive)

All Wordpress Themes

This topic contains 30 replies, has 3 voices, and was last updated by  Support Team 6 2 years, 11 months ago.

  • Author
    Posts
  • #25014

    mmarioolive
    Participant

    I was testing the website with this theme on ipad and images from sections “blank1”, “services”, “portfolio” are very large and zoomed-in and they lost their context and they seem abstract, How can I set up correctly those images on mobile devices?

    Please ask dor website adress and login detail privately if you need this to help.

    Thanks for the support.

  • #25016

    Support Team 4
    Participant

    Hello, mmarioolive!
    Give me link to your site and info about your device (OS, screen resolution and browser).

  • #25018

    mmarioolive
    Participant
    This reply has been marked as private.
    • #25019

      mmarioolive
      Participant

      By the way. The device is iPad Air 2 – safary browser

  • #25020

    Support Team 4
    Participant

    How I can login?

  • #25021

    mmarioolive
    Participant
    This reply has been marked as private.
  • #25022

    Support Team 4
    Participant

    ERROR 403 – Forbidden!

    • #25023

      mmarioolive
      Participant

      ok. sorry. I have country IP protection. give me a minute.

  • #25024

    mmarioolive
    Participant

    Please try now. I think it was a plugin.

  • #25025

    Support Team 4
    Participant

    No any effect.

  • #25026

    mmarioolive
    Participant

    I deactivate “under contstruction” for a while. Please try now

  • #25027

    Support Team 4
    Participant

    Works.

  • #25028

    Support Team 4
    Participant

    I can’t reproduce problem. Try to clear cache. If not help, give me screenshot from this device, please.

  • #25030

    mmarioolive
    Participant

    https://shots.testize.com/Results/Test/dc13232f-51bb-40b7-9797-82769f252111
    you can check here the issues in diferent devices and browsers

  • #25031

    Support Team 4
    Participant

    Try to add css code into style.css:

    .intro {
    	-moz-background-size: cover;
    	-webkit-background-size: cover;
    }

    After inserting code need to clear cache in browser.

  • #25032

    mmarioolive
    Participant

    No. Not work. Cache cleaned. Opened also in diffrent iPad. The same thing.

  • #25034

    Support Team 4
    Participant

    I sent you latest, test version of the theme, please, check on this version.

    • #25035

      mmarioolive
      Participant

      How can I change that files withou loose the configuration I have created? I activated the 2.3 theme and I lost the set up I had before.

  • #25036

    Support Team 4
    Participant

    You can activate old version, then go to Theme Options > Backup and copy and save code for options restore (for example into notepad). Then you should activate new version and again go to Theme Options > Backup and use saved code for restore theme options.

    • #25037

      mmarioolive
      Participant

      I have done. The issue persists. I think you have responsive problems with this theme…

  • #25038

    mmarioolive
    Participant

    Im using images with higth resolution 1940 × 1200. it can be because of that?

  • #25039

    Support Team 4
    Participant

    Try this css:

    @media screen and (max-width:319px) {
    section.intro {
        background-size: 100% auto;
    }
    }

    Hight resolution can’t cause problem. This problem of the browser. Browser doesn’t fully support standard of css3.

  • #25040

    Support Team 4
    Participant

    Sorry, above wrong code.
    Code:

    @media screen and (max-width:800px) {
    section.intro {
    	background-size: 100% auto;
    	-moz-background-size: 100% auto;
    	-webkit-background-size: 100% auto;
    	background-attachment: fixed;
    }
    }
  • #25041

    mmarioolive
    Participant

    doesn’t work. I put the css code in style.css (on root) and in css>style.css

    cache cleaned

  • #25042

    Support Team 4
    Participant

    I need to consult with our developers. Do you can don’t close site for 24 hours?

    • #25043

      mmarioolive
      Participant
      This reply has been marked as private.
  • #25044

    Support Team 4
    Participant

    Ok.
    We will contact when we have news.

  • #25053

    Support Team 6
    Participant

    Hello, mmarioolive!
    We have solution:
    1. Find file custom.js in folder wp-content\themes\oceanplaza\js and paste code as shown on a screeanshot http://prntscr.com/927ifa:

    var ua = navigator.userAgent.toLowerCase();
    
            this.android = ua.indexOf("android") > -1;
            this.iPhone = navigator.userAgent.match(/iPhone/i);
            this.iPad = navigator.userAgent.match(/iPad/i);
            this.mobile = this.android || this.iPhone || this.iPad;
    
            this.ie = $("html").hasClass("ie");
    
            if (!this.mobile) {
                $("body").addClass("desktop");
                $("html").addClass("desktop");
            }
            else {
                $("body").addClass("mobile");
                $("html").addClass("mobile");
            }

    2. Paste css rule in style.css:

    .mobile .intro {
    background-attachment: initial;
    }
    • #25065

      mmarioolive
      Participant

      Ok. It works!
      Thanks for the great support.

  • #25066

    Support Team 6
    Participant

    Hello, mmarioolive!
    Our team is glad to help you 🙂
    If you will not complicate, could you rate this theme on http://themeforest.net (log in, go to section “Download” and select needed amount of stars http://prntscr.com/3vxzil).
    Thanks in advance.

The topic ‘Images didnt set up correctly on mobile version (not responsive)’ is closed to new replies.